Monday, December 03, 2012

Update on Mactracker 7 System Requirements

I wanted to provide some information on why Lion was set as the minimum requirement for Mactracker 7.

My intent was to support Snow Leopard. When I moved version 7 to the Cocoa framework I encountered some stability issues with 10.6. Moving from a Carbon base was necessary for Retina display support.

I chose to release version 7 with the Lion requirement while I work to resolve the stability issues with Snow Leopard.

8 comments:

Anonymous said...

change the .plist to 10.6.8 and it works
so what problems did you have?
many thanks for your efforts but the decision to make it for lion and ml is definitely bad.
best wishes

Anonymous said...

I use OS 10.6.8 and the app automatically downloaded and installed itself. It wasn't until I tried to open it that I encountered trouble. If it won't run on my OS, can you not put a notice on it warning of the OS limitation? Or even prevent it from showing an update at all? As an aside, I have used MacTracker for many years. It is wonderful and genuinely useful. Thank you, and keep up the good work.

Anonymous said...

Thanks for working on Snow Leopard support :)

Anonymous said...

I emailed already, but it is incredibly lame to let it dowload and install to a computer it won't work on! IF you send me the 10.6.8 version I'll come backm and even donate, but you broke my Mactracker so noiw I have to use everymac.com.

Anonymous said...

Is there anything i can do to run it on 10.6.8? Tried changing the "Minimum system version" to 10.6 or 10.6.8 in info.plist but it didn't work...

Anonymous said...

Modifying the plist file worked for me.

Sebastian said...

Oh - sad day trying to open Mactracker on 10.6.8 after update ,-(

Happily did it open and works after changin "Minimum system" from 10.7 to 10.6 in the info.plist inside Contents on the app-package.

Please work on stability ,-)

jay paul said...

I really like your writing style. Such a nice Post, Can’t wait for the next one.

Acer - 14" Aspire Notebook - 4 GB Memory - 500 GB Hard Drive (V5-431-987B4G50Mabb)

Acer - 10.1" Aspire One Netbook - 1 GB Memory - 320 GB Hard Drive (AOD270-26Dkk)