Friday, November 14, 2014

1 comments:

Confused said...

Vr. 7.4 & 7.4.1 +? The download page offers 7.4+ files for Snow Leopard 10.6.8 and has links to the files. But the Release notes for 7.4 [ & other increments? ] says "System requirements updated to OS X 10.7 or later"
Why then is 7.4 file available for 10.6.8?
Will 7.4+ run on Snow Leopard?